XYMer's Home away from Home

When http://bbs.xlr8yourmac.com is down (i.e. always)
It is currently Tue Apr 25, 2017 12:29 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Thu Mar 09, 2017 8:38 am 
Offline
User avatar

Joined: Sun Nov 27, 2011 1:55 pm
Posts: 1849
I know about putting the partitions from my external HD into Privacy in Spotlight in Syst Prefs.

I repartitioned one of my externals, preparatory to storing it in the safe dep box.
I added the new partition by dragging it into the list of privacy in syst prefs - which usually means it won't index it and makes backups faster - or so I thought.
Problem is I apparently didn't do it fast enough before it began indexing it. Now it shows 74 seconds left of indexing - and has shown this for over 30 minutes. Finally I subtracted the partition from the privacy pane shut off the HD and figured OK. Then I turned it back on - and the 74 seconds left crawl bar has returned.

I am also seeing a dot in the center of the magnifying glass icon for spotlight. I don't remember that being there before. But I don't stare at it on a regular basis!

I've not got a lot of time to sort this out and the BU using superduper of the partition seemed to go OK though I'll do it once again before storing the HD.

What do I do to make it stop indexing? or how do I coax it to finish that 74 seconds? Will another BU do it? Should I leave the drives name in Privacy in Syst Pref or get it out.

Any suggestions much appreciated.
Thanks!

_________________
Mrs H


Top
 Profile  
 
PostPosted: Thu Mar 09, 2017 10:40 am 
Offline
User avatar

Joined: Thu May 15, 2008 8:13 pm
Posts: 9175
Location: Caught between the moon and NYC
Well I'm pretty sure you can do it from Terminal.

sudo mdutil -i off /Volumes/Volumenamegoeshere

And it should disable indexing on that volume. You can also just type sudo mdutil -i off and then drag the volume into the Terminal window to fill in the name for you. After you hit enter it'll request the password on your account.


Top
 Profile  
 
PostPosted: Thu Mar 09, 2017 11:04 am 
Offline
User avatar

Joined: Sun Nov 27, 2011 1:55 pm
Posts: 1849
Before you replied I looked online for info - sveral said, it can't be stopped.
I thought to let it run - still shows 74 seconds left - now 1.5 hours later. Folks said it could take days.
The HD put itself to sleep, the light isn't flashing which it does when it is working - indeed when I came back to it the light on the HD that shows it's on had gone out, but I woke up the iMac and the light came on again.

The dot in the spotlight is still pulsing. Still shows 74 seconds left.
What would happen if I changed the name of the partition and added the new partition with the name change to privacy?
You recall how much I love working in terminal???

EDIT: I tried adding the name of the folder as is to Privacy in Syst Pref again. dragging it over. It added fine. But still shows 74 seconds left.
Then I ejected the volume and finally ejected all the volumes and shut off the HD and disconnected it from the iMac.

It no longer gives the info of 74 seconds left to index ... when I click on Spotlight, but Spotlight icon mag glass still has the dot in it. The HD - before I disconnected it - was not pulsing blue just a steady blue light (Lacie HD), which means its sleeping, so no activity was going on. In fact, as I said above, when I left it alone, the light went out completely, total sleep no activity - it would stay 74 seconds forever.

I guess since the dot is still in Spotlight, it's still unhappy. I just need to get through this week without a crisis. What happens if I do nothing????

FURTHER EDIT:
Mr H said "restart" - that worked to take away the dot in spotlight.
I haven't solved the index problem, but at least spotlight is happy for the time being.

MonkeyBoy: If I do your terminal command, can it screw up anything?
What if at a later date, I do want the volume to be indexed and accessible via spotlight - how do I undo this?

_________________
Mrs H


Top
 Profile  
 
PostPosted: Thu Mar 09, 2017 6:28 pm 
Offline
User avatar

Joined: Thu May 15, 2008 8:13 pm
Posts: 9175
Location: Caught between the moon and NYC
Turning it back on is as simple as
sudo mdutil -i on /Volumes/Volumenamegoeshere

Hmm. Isn't there a . file you can create in the root to tell it not to index it? When the disk mounts spotlight looks in the root, sees the file, and skips indexing it. Can't remember. Too sleepy. To get that indexing again you just rm the . file and eject/insert the disk again. I just can't remember what the name of the file is beyond that it starts with a .

I think I did the latter to one of the disks at home, I'll have to check.


Top
 Profile  
 
PostPosted: Thu Mar 09, 2017 10:33 pm 
Offline

Joined: Thu Jul 05, 2012 4:02 pm
Posts: 943
Location: Melbourne
Here it is MB. I use this myself.

sudo touch /Volumes/name_of_your_drive/.metadata_never_index


Top
 Profile  
 
PostPosted: Fri Mar 10, 2017 12:53 am 
Offline
User avatar

Joined: Thu May 15, 2008 8:13 pm
Posts: 9175
Location: Caught between the moon and NYC
That's the one I was thinking of. I, uh, don't have that file on any of my external drives at home. I had it at one point on some of my externals... :oops:

After I switched over to the Sonnet eSATA card I undid a lot of the hackery that was made trying and get the old eSATA card stable. The Sonnet was bought used too... only bad thing is the Sonnet's not bootable.


Oh. Yeah. So to create that file you would open terminal, type
touch (drag volume to terminal window here)/.metadata_never_index

and then hit enter. This will create a file called .metadata_never_index in the root of the HD you dragged. Since it starts with a . you won't see it from Finder or even from Terminal (you can use ls -al to show them but normal ls will omit files that start with .).

To remove the file you would do the same but type
rm (drag volume to terminal window here)/.metadata_never_index

to remove the file.

If this is a volume which you cleared the "ignore permissions on this volume" setting in the get info box, then you may need to preface the command with sudo. This is because you may need to be a super-user (super user do = sudo) to write to the root of the HD. A bootable backup is one such variation. I think if you need sudo it will kick back an error when trying to write the file without sudo.


Top
 Profile  
 
PostPosted: Sun Mar 12, 2017 7:53 am 
Offline
User avatar

Joined: Sun Nov 27, 2011 1:55 pm
Posts: 1849
Thanks all for the help.

I didn't solve this one yet, but it was time to move that HD to the safe deposit box.
I'll be back with further questions on this if the problem persists.

_________________
Mrs H


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group